我想自定义组件 ,引入layaeditor.d.ts直接编译,居然报这个文件有错

按官方的腾讯课程, 我想自定义组件 ,引入layaeditor.d.ts后直接编译,居然报这个文件有错? 是版本问题吗, 因为教程用的版本和现在的好像不是一样的。。 。有没有解决办法呢?
出错了:
TypeScript error: libs/layaeditor.d.ts(1106,37): Error TS2551: Property 'Component' does not exist on type 'typeof ui'. Did you mean 'UIComponent'?
已邀请:

三五七

赞同来自: 晴天73

已解决

Laya_Aaron

赞同来自:

你用的引擎是哪个版本的?教程的那个版本很老。建议看一看官方文档的。

三五七

赞同来自:

根本没法编译成功啊... 已经F9设置了分离模式了, 按文档来的呀, 不知道还有哪有问题

三五七

赞同来自:

我都不纠结这个报错了, custom目录里自带了这个scaleButton的JS和XML, 设计模式已经可以用了, 只是要在哪里注册这个组件 呢, 按视频 教程里的在layaMaxUI.ts里注册。。。  这个文件是自动生成的, 一编译就没了, 到底是在哪里注册啊

三五七

赞同来自:

老大麻烦帮我看看哇,搞了一天了,  现在设计模式是可以正常设计界面了, 运行找不到类...

三五七

赞同来自:

这不是已经导入类了吗, 为什么还会找不到类呢?

Laya_Aaron

赞同来自:

http://ldc2.layabox.com/doc/?nav=zh-ts-2-2-3   这个文档到哪一步出问题了?

该问题目前已经被锁定, 无法添加新回复

商务合作
商务合作