版本管理问题

在ide 2.0的发布版本里否选启用版本管理点发布后会出现问题
index.js里的loadLib用的文件名还是未改名后的文件
如下
//-----libs-begin-----
loadLib("libs/laya.core.js");
loadLib("libs/laya.webgl.js");
loadLib("libs/laya.ui.js");
loadLib("libs/laya.physics.js");
//-----libs-end-------
loadLib("js/bundle.js");

因为src下里的Main.ts里调用的管理版本器会编译成bundle.js
也是最后调用的.
导致这些库都找不到,游戏无法启动
已邀请:

Apple

赞同来自:

基础库可以手动考一份进去,把带版本号的删掉。基础库并不会和逻辑一起频繁更新,所以可以先暂时这么用。

lzsong

赞同来自:

2.0正式版貌似解决了这个问题 之前确实有

nevercai

赞同来自:

使用新版的发布3.0功能就好了。
但是也不是很友好,不能自定义js合并。

要回复问题请先

商务合作
商务合作