发布微信小游戏后,再编译会报错, please use 'module: "ES2015"' or 'module: "ESNext"'

发布微信小游戏后,再编译项目会报错
 
微信图片_20191015191024.png
已邀请:

kylin

赞同来自:

1) 打开发布页面以后,IDE会对编译发布脚本进行版本号检测,会更新到最新的脚本。
2) 自2.2.0以后,引擎全面转向es6,es6的编译和es5完全不同
3.1) 可以手动将编译脚本(.laya/compile.js)的版本号改为高版本
3.2) 也可以使用旧IDE
3.3) 为了能及时获取最新的引擎支持,我们建议新项目转为2.2.0及以上版本的引擎

房建业

赞同来自:

请问这个问题解决了吗?怎么解决的
 

要回复问题请先

商务合作
商务合作