2.4.0怎么调试呢?

如题,调试按钮没有了
TIM截图20191113175654.png
已邀请:

倚天

赞同来自:

LayaAirIDE[b]剥离 [b][b]VSCode[/b][/b]编码工具[/b]   一直以来,LayaAirIDE都是以内置VSCode编码工具用于LayaAir项目开发,好处是与项目的紧密度更好,创建项目后自动打开项目的编码模式,然而一个不太有利的地方,就是由于IDE整合时会对VSCode接口作出修改,且与IDE自有功能对接的耦合度比较高,导致更新VSCode工具版本与IDE整合的成本也比较高,所以LayaAirIDE不会轻易更新VSCode版本,这也会让一些开发者不能享受到VSCode新版本的功能,或者一些小问题不能得到及时通过更新VSCode处理。 从2.4.0 beta开始,LayaAirIDE中,仍然可以创建项目、调起chrome运行、发布项目、管理项目。但编码工具是直接跳转到开发者自行安装的VSCode工具版本中,开发者无论使用任何VSCode版本,安装任何VSCode插件,都是开发者自由的选择,与LayaAirIDE不再有直接的关系。


因IDE机制的原因,MAC版IDE,LayaAirIDE中启动编码模式,只能调起VSCode,无法自动打开项目


对于IDE的此次升级,还对IDE和项目模板做了一些瘦身,所以我们建议去官网下载全新的2.4.0 beta版本,采用升级的方式来更新到LayaAirIDE 2.4.0,将无法享受到IDE和新建项目时的瘦身好处。

Chiuan

赞同来自:

配置下vsc启动就行。。

ankye大华

赞同来自:

试试将 VSCode 配置中的
debug.allowBreakpointsEverywhere
设置为
true

奶我嘛

赞同来自:

在vs中生成luanch.json,下载插件bugger for chrome,直接在vs这边f5就可以运行并调试断点了,如果还是不行,直接从旧版的laya项目里copy一个luanch.json过来就可以了

zhdeer

赞同来自:

感觉改了之后更加不方便了。有时候几个项目的频繁切换也是很浪费时间的。

ankye大华

赞同来自:

"sourceMap": true
改的地方和2.3类似,我现在可以调试了

要回复问题请先

商务合作
商务合作