安装layaair2-cmd一直失败

C:\Users\Administrator>npm i layaair2-cmd -g
npm WARN deprecated core-js@2.6.11: core-js@<3 is no longer maintained and not recommended for usage
 due to the number of issues. Please, upgrade your dependencies to the actual version of core-js@3.
C:\Users\Administrator\AppData\Roaming\npm\layaair2-cmd -> C:\Users\Administrator\AppData\Roaming\np
m\node_modules\layaair2-cmd\layaair2-cmd.js

> core-js@2.6.11 postinstall C:\Users\Administrator\AppData\Roaming\npm\node_modules\layaair2-cmd\no
de_modules\core-js
> node -e "try{require('./postinstall')}catch(e){}"

Thank you for using core-js ( https://github.com/zloirock/core-js ) for polyfilling JavaScript stand
ard library!

The project needs your help! Please consider supporting of core-js on Open Collective or Patreon:
> https://opencollective.com/core-js
> https://www.patreon.com/zloirock

Also, the author of core-js ( https://github.com/zloirock ) is looking for a good job -)


> jpeg-recompress-bin@4.0.0 postinstall C:\Users\Administrator\AppData\Roaming\npm\node_modules\laya
air2-cmd\node_modules\jpeg-recompress-bin
> node lib/install.js

  × RequestError: read ECONNRESET
    at ClientRequest.<anonymous> (C:\Users\Administrator\AppData\Roaming\npm\node_modules\layaair2-c
md\node_modules\bin-wrapper\node_modules\got\index.js:182:22)
    at Object.onceWrapper (events.js:300:26)
    at ClientRequest.emit (events.js:210:5)
    at TLSSocket.socketErrorListener (_http_client.js:406:9)
    at TLSSocket.emit (events.js:210:5)
    at emitErrorNT (internal/streams/destroy.js:92:8)
    at emitErrorAndCloseNT (internal/streams/destroy.js:60:3)
    at processTicksAndRejections (internal/process/task_queues.js:80:21)

> gifsicle@4.0.1 postinstall C:\Users\Administrator\AppData\Roaming\npm\node_modules\layaair2-cmd\no
de_modules\gifsicle
> node lib/install.js

  ‼ read ECONNRESET
  ‼ gifsicle pre-build test failed
  i compiling from source
  × Error: Command failed: C:\Windows\system32\cmd.exe /s /c "autoreconf -ivf"
'autoreconf' �����ڲ����ⲿ���Ҳ���ǿ����еij���
���������ļ���


    at C:\Users\Administrator\AppData\Roaming\npm\node_modules\layaair2-cmd\node_modules\execa\index
.js:231:11
    at processTicksAndRejections (internal/process/task_queues.js:93:5)
    at async Promise.all (index 0)
npm WARN notsup Unsupported engine for got@5.7.1: wanted: {"node":">=0.10.0 <7"} (current: {"node":"
12.13.0","npm":"6.12.0"})
npm WARN notsup Not compatible with your version of node/npm: got@5.7.1
npm WARN notsup Unsupported engine for got@5.7.1: wanted: {"node":">=0.10.0 <7"} (current: {"node":"
12.13.0","npm":"6.12.0"})
npm WARN notsup Not compatible with your version of node/npm: got@5.7.1

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! gifsicle@4.0.1 postinstall: `node lib/install.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the gifsicle@4.0.1 postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Administrator\AppData\Roaming\npm-cache\_logs\2020-02-11T10_54_16_317Z-debug.l
og
 
 
2020-02-11T10_54_16_317Z-debug.log
 
31916 info lifecycle jpeg-recompress-bin@4.0.0~postinstall: jpeg-recompress-bin@4.0.0
31917 verbose lifecycle jpeg-recompress-bin@4.0.0~postinstall: unsafe-perm in lifecycle true
31918 verbose lifecycle jpeg-recompress-bin@4.0.0~postinstall: PATH: C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin;C:\Users\Administrator\AppData\Roaming\npm\node_modules\layaair2-cmd\node_modules\jpeg-recompress-bin\node_modules\.bin;C:\Users\Administrator\AppData\Roaming\npm\node_modules\layaair2-cmd\node_modules\.bin;C:\Users\Administrator\AppData\Roaming\npm\node_modules\.bin;C:\Users\Administrator\.gradle\wrapper\dists\gradle-4.4-all\9br9xq1tocpiv8o6njlyu5op1\gradle-4.4\bin;D:\Android\Sdk\platform-tools;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Git\cmd;C:\Android;C:\Windows\System32;C:\Program Files\TortoiseSVN\bin;C:\Program Files\nodejs\;C:\Users\Administrator\.gradle\wrapper\dists\gradle-4.4-all\9br9xq1tocpiv8o6njlyu5op1\gradle-4.4\bin;D:\Android\Sdk\platform-tools;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Git\cmd;C:\Android;C:\Windows\System32;C:\Program Files\TortoiseSVN\bin;C:\Program Files\nodejs\;E:\COCOS\cocos2d-x-3.17.2\templates;E:\COCOS\cocos2d-x-3.17.2\tools\cocos2d-console\bin;E:\COCOS\Python\Python27;E:\COCOS\apache-ant-1.10.7\bin;C:\Users\Administrator\AppData\Roaming\npm;C:\Users\Administrator\AppData\Local\Programs\Microsoft VS Code\bin;C:\Program Files (x86)\Egret\Egret Wing 3\bin
31919 verbose lifecycle jpeg-recompress-bin@4.0.0~postinstall: CWD: C:\Users\Administrator\AppData\Roaming\npm\node_modules\layaair2-cmd\node_modules\jpeg-recompress-bin
31920 silly lifecycle jpeg-recompress-bin@4.0.0~postinstall: Args: [ '/d /s /c', 'node lib/install.js' ]
31921 silly lifecycle jpeg-recompress-bin@4.0.0~postinstall: Returned: code: 0  signal: null
31922 silly postinstall download@6.2.5
31923 info lifecycle download@6.2.5~postinstall: download@6.2.5
31924 silly postinstall bin-build@3.0.0
31925 info lifecycle bin-build@3.0.0~postinstall: bin-build@3.0.0
31926 silly postinstall gifsicle@4.0.1
31927 info lifecycle gifsicle@4.0.1~postinstall: gifsicle@4.0.1
31928 verbose lifecycle gifsicle@4.0.1~postinstall: unsafe-perm in lifecycle true
31929 verbose lifecycle gifsicle@4.0.1~postinstall: PATH: C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\node-gyp-bin;C:\Users\Administrator\AppData\Roaming\npm\node_modules\layaair2-cmd\node_modules\gifsicle\node_modules\.bin;C:\Users\Administrator\AppData\Roaming\npm\node_modules\layaair2-cmd\node_modules\.bin;C:\Users\Administrator\AppData\Roaming\npm\node_modules\.bin;C:\Users\Administrator\.gradle\wrapper\dists\gradle-4.4-all\9br9xq1tocpiv8o6njlyu5op1\gradle-4.4\bin;D:\Android\Sdk\platform-tools;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Git\cmd;C:\Android;C:\Windows\System32;C:\Program Files\TortoiseSVN\bin;C:\Program Files\nodejs\;C:\Users\Administrator\.gradle\wrapper\dists\gradle-4.4-all\9br9xq1tocpiv8o6njlyu5op1\gradle-4.4\bin;D:\Android\Sdk\platform-tools;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Git\cmd;C:\Android;C:\Windows\System32;C:\Program Files\TortoiseSVN\bin;C:\Program Files\nodejs\;E:\COCOS\cocos2d-x-3.17.2\templates;E:\COCOS\cocos2d-x-3.17.2\tools\cocos2d-console\bin;E:\COCOS\Python\Python27;E:\COCOS\apache-ant-1.10.7\bin;C:\Users\Administrator\AppData\Roaming\npm;C:\Users\Administrator\AppData\Local\Programs\Microsoft VS Code\bin;C:\Program Files (x86)\Egret\Egret Wing 3\bin
31930 verbose lifecycle gifsicle@4.0.1~postinstall: CWD: C:\Users\Administrator\AppData\Roaming\npm\node_modules\layaair2-cmd\node_modules\gifsicle
31931 silly lifecycle gifsicle@4.0.1~postinstall: Args: [ '/d /s /c', 'node lib/install.js' ]
31932 silly lifecycle gifsicle@4.0.1~postinstall: Returned: code: 1  signal: null
31933 info lifecycle gifsicle@4.0.1~postinstall: Failed to exec postinstall script
31934 timing action:postinstall Completed in 18553ms
31935 verbose unlock done using C:\Users\Administrator\AppData\Roaming\npm-cache\_locks\staging-abc99ad82fab7dbe.lock for C:\Users\Administrator\AppData\Roaming\npm\node_modules\.staging
31936 timing stage:rollbackFailedOptional Completed in 3367ms
31937 timing stage:runTopLevelLifecycles Completed in 192968ms
31938 warn notsup Unsupported engine for got@5.7.1: wanted: {"node":">=0.10.0 <7"} (current: {"node":"12.13.0","npm":"6.12.0"})
31939 warn notsup Not compatible with your version of node/npm: got@5.7.1
31940 verbose notsup Not compatible with your version of node/npm: got@5.7.1
31940 verbose notsup Required: {"node":">=0.10.0 <7"}
31940 verbose notsup Actual:   {"npm":"6.12.0","node":"12.13.0"}
31941 warn notsup Unsupported engine for got@5.7.1: wanted: {"node":">=0.10.0 <7"} (current: {"node":"12.13.0","npm":"6.12.0"})
31942 warn notsup Not compatible with your version of node/npm: got@5.7.1
31943 verbose notsup Not compatible with your version of node/npm: got@5.7.1
31943 verbose notsup Required: {"node":">=0.10.0 <7"}
31943 verbose notsup Actual:   {"npm":"6.12.0","node":"12.13.0"}
31944 verbose stack Error: gifsicle@4.0.1 postinstall: `node lib/install.js`
31944 verbose stack Exit status 1
31944 verbose stack     at EventEmitter.<anonymous> (C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\index.js:332:16)
31944 verbose stack     at EventEmitter.emit (events.js:210:5)
31944 verbose stack     at ChildProcess.<anonymous> (C:\Program Files\nodejs\node_modules\npm\node_modules\npm-lifecycle\lib\spawn.js:55:14)
31944 verbose stack     at ChildProcess.emit (events.js:210:5)
31944 verbose stack     at maybeClose (internal/child_process.js:1021:16)
31944 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:283:5)
31945 verbose pkgid gifsicle@4.0.1
31946 verbose cwd C:\Users\Administrator
31947 verbose Windows_NT 6.1.7601
31948 verbose argv "C:\\Program Files\\nodejs\\node.exe" "C:\\Program Files\\nodejs\\node_modules\\npm\\bin\\npm-cli.js" "i" "layaair2-cmd" "-g"
31949 verbose node v12.13.0
31950 verbose npm  v6.12.0
31951 error code ELIFECYCLE
31952 error errno 1
31953 error gifsicle@4.0.1 postinstall: `node lib/install.js`
31953 error Exit status 1
31954 error Failed at the gifsicle@4.0.1 postinstall script.
31954 error This is probably not a problem with npm. There is likely additional logging output above.
31955 verbose exit [ 1, true ]
 
已邀请:

Laya_Aaron

赞同来自:

装那个类库失败了,单独装一次该类库(目前已知gulp-image失败几率较大),如果单独装成功了,再次装cmd2,大概率会成功

Ace1024

赞同来自:

我的也是这样

Bob.Song

赞同来自:

楼主怎么解决的?我也碰到这个问题。各种办法都没法解决

gamedaybyday2

赞同来自:

我就没装成功过。

185*****024

赞同来自:

我的也是失败, 2.4版本, 
 
安装的时候说 需要把 "babel-preset-es2015" 升级到 "babel-preset-env"
 
但是后面安装又报了其他错..

Snipaste_2020-04-18_19-13-54.png

 

哦哦哦(´-ω-`)

赞同来自:

大佬们都是怎么解决的
 

1589466516用户

赞同来自:

vv> gifsicle@4.0.1 postinstall C:\Users\Administrator\AppData\Roaming\npm\node_modules\layaair2-cmd\no
de_modules\gifsicle
> node lib/install.js 
> jpeg-recompress-bin@4.0.0 postinstall C:\Users\Administrator\AppData\Roaming\npm\node_modules\laya
air2-cmd\node_modules\jpeg-recompress-bin
> node lib/install.js
 这两步似乎你没有下成功,GitHub的资源库dns污染很严重,你在host里加上
52.74.223.119     github.com
192.30.253.119    gist.github.com
54.169.195.247    api.github.com
185.199.111.153   assets-cdn.github.com
151.101.76.133    raw.githubusercontent.com
151.101.76.133    gist.githubusercontent.com
151.101.76.133    cloud.githubusercontent.com
151.101.76.133    camo.githubusercontent.com
151.101.76.133    avatars0.githubusercontent.com
151.101.76.133    avatars1.githubusercontent.com
151.101.76.133    avatars2.githubusercontent.com
151.101.76.133    avatars3.githubusercontent.com
151.101.76.133    avatars4.githubusercontent.com
151.101.76.133    avatars5.githubusercontent.com
151.101.76.133    avatars6.githubusercontent.com
151.101.76.133    avatars7.githubusercontent.com
151.101.76.133    avatars8.githubusercontent.com
 
然后清除所有缓存试试
我的node8.11 成功安装

要回复问题请先

商务合作
商务合作