mac上的chrome解决跨域问题(打不开本地文件请求)

刚试过,可用的解决方法:
设置方法:
打开一个新的可跨域的chrome窗口实现方法:
1. 打开终端
2. 输入下面的命令( 需要替换路径中的yourname )
open -n /Applications/Google\ Chrome.app/ --args --disable-web-security  --user-data-dir=/Users/yourname/MyChromeDevUserData/
注意:
Mac下可使用命令行打开chrome,记住先关闭当前chrome窗口。
网上有些文章--user-data-dir参数后面没有添加文件夹名,是设置不成功的。
这是在mac的根目录在建了一个叫MyChromeDevUserData的文件夹,用于保存关闭安全策略后的用户信息的,名字可以随意取,位置也可以随意放,只要路径是正确的就可以。
发现:
第一次打开chrome有黄色背景色的“--disable-web-security”相关的提示,说明浏览器设置跨域成功。
再次用执行上面的命令行时,不会再有相关提示了,但是还是能跨域的!
已邀请:

Laya_Aaron

赞同来自:

这篇分享真是太棒了,专业的排版和描述~!

该问题目前已经被锁定, 无法添加新回复

商务合作
商务合作