layaair2-cmd 7天前发布的最新版本1.4.4存在问题

使用7天前发布的最新的命令行工具执行编译发布时都会报这个错误,/h5game_src/develop/laya是我们的项目路径,检查了layaair2-cmd/node_modules里依赖都有的,但是不懂为什么要去项目目录找gulp依赖,麻烦处理一下~

[root@localhost layaair2-cmd]# layaair2-cmd compile -w /h5game_src/develop/laya

Local gulp not found in /h5game_src/develop/laya/.laya
[16:23:49] Try running: npm install gulp

exit:1
 
另外全局gulp已经安装,看了下layaair2-cmd 1.4.4版本工具的脚本js,把里面新改的fork执行改成了spawn也没有用,报同样的错误。
另外package.json是改成1.4.4了,但是layaair2-cmd -v时还是输出1.4.3,不免让人confuse,也麻烦同步一下
QQ截图20191018164219.jpg
已邀请:

陆仁毅

赞同来自:

这个问题需要等ide发版,目前只能使用1.3.0版本。或者你可以自己改下.laya下的编译和发布脚本,吧
useIDENode
变量整成true试试

要回复问题请先

商务合作
商务合作