LayaNative在Android 11上启动闪退

事件起因:自8月起,GP提交新应用必须以API级别30为目标平台,并使用Android App Bundle发布格式
 
测试环境:
1、LayaAir IDE 2.5.0
2、Native版本:release-v2.5.0
 
复现步骤:
1、使用IDE新建一个3D示例项目

1630298982467.jpg

 
2、文件-项目设置-类库设置,勾选物理引擎库laya.physics3D.js

1630299099372.jpg

 
3、使用工具构建一个Native工程

1630299916911.jpg

 
4、使用Android Studio打开工程,把目标API改成30

1630299234536.jpg

 
5、编译运行在Android 11系统的手机上
5、游戏启动时闪退
 
下面的Crash可做参考

截屏2021-08-26_下午6.38_.52_.png

 
我试了其他版本的引擎,都有相同问题
已邀请:

黄豆

赞同来自: layabox Yan-Laya

我也遇到了这个问题,目前LAYA那边已经解决了这个问题,试试用这个

1630297435用户

赞同来自:

另外我用最新的2.12.1beta版本测试时,遇到和这位同学一样的问题https://ask.layabox.com/question/49250
 
测试环境:
1、LayaAir IDE 2.12.1beta
2、Native版本:release-v2.12.0
 
步骤和上面一样,附件是DEMO
(因为文件较大,无法上传,拆分成两个,解压后把release放到Laya3D_2121目录即可)

莲子君w

赞同来自:

遇到了相同的问题,替换了楼上所述的2.12.0so依然不解决问题

该问题目前已经被锁定, 无法添加新回复

商务合作
商务合作