上GOOGLE被打回概述问题为使用了不合规的Layaair Autoupdate SDK版本

项目IDE版本为:2.10.0
项目引擎版本为:2.10.0
项目NATIVE版本为:2.12.2
10月18号左右上线的游戏打回于以下原因
 嗨,XXX的开发人员
经过最近的审核,我们发现你的应用XXXXXXX不符合我们的一项或多项开发人员计划政策。有关您的应用程序状态以及如何解决问题的更多信息,请参阅下文。
违规原因
你的应用程序有问题
你的应用包含不符合设备和网络滥用政策的内容。我们发现您的应用使用包含不符合设备和网络滥用政策的内容。我们发现您的应用使用了不合规的Layaair Autoupdate SDK 版本,其中包含用于从Google Play之外的未知来源下载或安装应用的代码。
 
如有必要,你可以咨询你的SDK提供商以获取更多信息。
 
受影响的版本:
应用程序包:2
已邀请:

竹心

赞同来自:

删除autoupdateversion文件夹,删除config.ini 下面的链接过审了

Laya_Yan

赞同来自:

将更新apk相关的代码删掉,这个文件夹下的

黄豆

赞同来自:

原文是这个
 
Hi Developers at XXXXXXX,After a recent review, we found that your app XXXXXXXXXXXXXX is not compliant with one or more of our Developer Program Policies. See below for more information about your app’s status and how to correct the issue.
file:///D:\AppData\QQData\415096750\Image\C2C\A@REEY]N8QYGCND)RRO37OT.JPG
Issue with your appYour app contains content that doesn’t comply with the Device and Network Abuse policy. We found your app is using a non-compliant version of Layaair Autoupdate SDK which contains code to download or install applications from unknown sources outside of Google Play.

If necessary, you can consult your SDK provider(s) for further information.

Affected Version(s):
App Bundle:3
file:///D:\AppData\QQData\415096750\Image\C2C\$%PO57OO98_)NDA]}%K7}%W.JPG
About the Device and Network Abuse policyAn app distributed via Google Play may not modify, replace, or update itself using any method other than Google Play's update mechanism. Likewise, an app may not download executable code (e.g. dex, JAR, .so files) from a source other than Google Play. This restriction does not apply to code that runs in a virtual machine or an interpreter where either provides indirect access to Android APIs (such as JavaScript in a webview or browser).

Apps or third-party code (e.g., SDKs) with interpreted languages (JavaScript, Python, Lua, etc.) loaded at run time (e.g., not packaged with the app) must not allow potential violations of Google Play policies. Please note that you are responsible for all aspects of your app; by using an SDK in your app, you are responsible for how that SDK behaves within your app.
file:///D:\AppData\QQData\415096750\Image\C2C\YAR)PE9(8UBZZG1N7$(X2ZI.JPG
App status:SuspendedYour app has been suspended and removed due to this policy issue.

ye

赞同来自:

我也遇到了,是不是谷歌那边更新东西了?前几个月还没事。

sands

赞同来自:

laya官方有解答一下吗,是不是库里有调用到热更了,我们渠道laya批量被下架了

该问题目前已经被锁定, 无法添加新回复

商务合作
商务合作