使用2.1.1.1引擎创建的ts小游戏升级2.3.0版本之后无法进入游戏

使用2.1.1.1引擎创建的ts小游戏升级2.3.0版本之后无法进入游戏,LayaMaxUI在继承场景时会报一个错 : Class constructor Scene cannot be invoked without 'new'
下附错误截图及demo
B46GQ3X(3M15WI85RN}(UE8.png
已邀请:

kylin

赞同来自:

2.2.0引擎全面转入es6,如果使用以前的编译而使用新版本的引擎库,就会出现这种问题。
 
建议使用新版本IDE升级引擎库,会自动更新相关配置文件,打开发布面板,升级编译发布脚本,项目就可以全面转入es6开发了

赞同来自:

这是新版IDE替换的引擎库,然后还升级了编译文件,结果还是会出现上面的报错

要回复问题请先

商务合作
商务合作