【QQ轻游戏】【QQ开发者工具v0.1.28 + Laya2.3.0】编译黑屏情况

创建新的Laya3d示例项目。
打包QQ轻游戏。
用QQ小程序开发者工具打开。
 
[直接创建的示例项目,然后用的QQ开发者测试号   -  LayaIDE 2.3.0beta QQ开发工具v0.1.28]
 
1、首先会提示 没有long.js
     我放了一个到lib下.
     没问题了
 
2   编译,手机调试画面一直黑屏,没有反应,控制台两行警告.
 
3   项目设置:ES6转ES5,项目报错 "文件libs/laya.ui.js执行出现异常 "

1.png

 
-------------------------------------------------------------
请教一下这是什么情况需要怎么解决.
 
demo的话就是新建一个Laya3d物理示例项目
 
项目设置
2.png



---------------------------------------------------------------
最新情况:
      v0.1.27没有盒子广告的API库,所以用v0.1.28版本调试
     但是v0.1.28的QQ开发者工具,会出现黑屏的情况.
     希望帮处理一下,或者给个解决办法.
     环境 v0.1.28  + Laya 2.3.0  win10  测试过两台电脑,都是这样
 
已邀请:

Laya_Aaron

赞同来自:

不用你的demo是不行的, 版本都没说

Laya_Aaron

赞同来自:

而且这个不像是引擎问题,引擎这么多游戏都上了。。还是传demo看看

Laya_Aaron

赞同来自:

没啥问题, 看看 qq工具里详情  alpha 版本库 是否勾选,不要勾选

匿名用户

赞同来自:

不知道怎么解决.
现在就不知道什么情况,我的demo官方运行又可以,
 
天啦噜.ala
 
alpha版本库是什么东西,找不到

kylin

赞同来自:

1) 不要在QQ开发者工具里勾选"ES6转ES5"
2) 如果确实有ES6转ES5的需求,是用LayaAirIDE自带的(在发布面板上),2.4.0版本的IDE已经增加了这个功能

匿名用户

赞同来自:

【问题已经解决了】
 
我用的是      Laya 2.3.0beta
 
QQ开发者工具 目前官网最新的       v0.1.28
 
没法打包运行。我找了        v0.1.27      就可以运行了。
 
感谢楼上耐心回答。
 

匿名用户

赞同来自:

最新情况:
      v0.1.27没有盒子广告的API库,所以必须用v0.1.28版本
     但是v0.1.28的QQ开发者工具,会出现黑屏的情况.
     希望帮处理一下,或者给个解决办法.
     环境 v0.1.28  + Laya 2.3.0  win10  测试过两台电脑,都是这样

要回复问题请先

商务合作
商务合作