引擎版本2.4.0打包微信小游戏报错,开发者工具正常,真机运行报错

tsconfig.json配置是:
{
"compilerOptions": {
"module": "esnext",
"target": "es6",
"lib": [ "dom", "es5", "es2015.promise" ],
"noEmitHelpers": true,
"sourceMap": false
},
"exclude": [
"node_modules"
]
}

 真机报错截图

QQ20200324-0.png

 
开发者工具设置不勾选ES6转ES5和增强编译就不会报错,但在手机上就会有上面的报错。
QQ20200324-225132.png

 
如果勾选了ES6转ES5就会报错:
QQ20200324-225330.png

QQ20200324-225414.png


QQ20200324-225414.png


增加了官方案例demo,用了最简单的async await都会报错
 
已邀请:

鹿

赞同来自:

只勾选ES6转ES5不勾选增强编译的话就会报错:

QQ20200324-231819.png

 

要回复问题请先

商务合作
商务合作